it.ubc.ca - Website Down 09:20 PT, Friday August 8, 2025

Incident Report for UBC

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 17:21 PDT

Identified

UBC IT technicians have identified the issue and have restored all services; they will continue to monitor the services to ensure their stability.
Posted Aug 08, 2025 - 14:01 PDT

Investigating

As of 09:20 PT today, the it.ubc.ca website is unavailable. UBC IT technicians are currently investigating the issue and working on restoring all services.
Posted Aug 08, 2025 - 14:01 PDT
This incident affected: Other (Other - Vancouver, Other - Okanagan).